"Debug build" feature does not recreate context properly for iOS builds

For Travis-CI employees the build that can be reproduced: https://travis-ci.com/github/JunGroupProductions/Mobile-SDK/jobs/407817669

Steps to reproduce:

  1. Trigger the build
  2. Wait till the build has finished. Take a note what is the last step finished.
  3. Debug the build, do “travis_run_before_install” && “travis_run_install” , execute steps from the “script” block of the .travis.yml

Expected behavior:

  • the same result from step (2)

Actual result:

  • xcodebuild command fails with “[!] No simulators found on local machine”

Triggering the build for the same commit will not reproduce the behavior, so most likely just “debug build” is affected.

A little bit of context:
os: osx
language: node_js
osx_image: xcode12.1
podfile: iOS/Podfile
addons:
chrome: stable
cache:
bundler: true
cocoapods: true
yarn: true
directories:
- Shared/shared_js/node_modules

1 Like

Having a similar issue in Debug Mode attempting to use fastlane scan

I ran travis_run_before_install travis_run_install travis_run_before_script travis_run_script

Build seems to be successful but the command fails with “no simulators found”

Ran xcrun simctl list returns a full list of installed simulators.

Imprint