Confusing PyPy versions


#1

In order to run tests with PyPy 3.5, I can just specify it as pypy3.5 as mentioned in the docs at https://docs.travis-ci.com/user/languages/python/#pypy-support
In this case the version is:

$ python --version
Python 3.5.3 (3f6eaa010fce, Jan 11 2018, 04:44:35)
[PyPy 5.10.1 with GCC 6.2.0 20160901]

The docs also say that one can test with PyPy (meaning 2.7-x branch I suppose):

Travis CI supports PyPy and PyPy3.

But when one tries to set pypy or pypy2.7, it fails to download it from S3.

I have found that I can get it to work with pyp2.7-6.0 (see https://github.com/travis-ci/travis-ci/issues/9542), but not sure if it’s possible to get 2.7-5.x somehow.

Versions that fail:

  - pypy
  - pypy2
  - pypy2.7
  - pypy2.7-5.10
  - pypy2.7-5.10.1
  - pypy2.7-7.0
  - pypy3
  - pypy3.5-5.10
  - pypy3.5-5.10.1
  - pypy3.5-7.0

Versions that work:

  - pypy2.7-6.0
  - pypy3.5  # == 5.10.1 atm
  - pypy3.5-6.0

The working versions need to be mentioned in the docs at least. Ideally one would want to have an explicit way to select a version, as in case of 6.0. I feel that pypy3.5 archive can get updated to a newer version, but it would be great to be still able to test against 5.x.

Any plans for pypy2.7-7.0 and pypy3.5-7.0?

Similar threads






Document supported pypy versions
#2

@andreif FTR it should be pypy3.6-7.0.0 (not 3.5) once available.


#3

Lol, thanks!