Cannot migrate repository

I am trying to migrate one of the repository from .org -> .com: https://travis-ci.com/github/controlsfx/controlsfx

One travis.com, I see the following:

When I press “Migrate” button, the text on the button changes to “Migrating” and that’s it. I have migrate repositories in the past successfully, so I have an idea on how this works.

I have tried multiple times and every time its stuck:

travis

Following are a few notes about this repository:

  1. It had the deprecated webhooks for both .com and .org. However, we were using .org since we weren’t able to get few things right on .com. Therefore, you can see a few builds in .com.
  2. I removed webhooks for both .com and .org. Installed Github App for Travis and then ran the migration. Since it didn’t complete, I have re-installed the webhook for .org for the time being.
1 Like

Hey @abhinayagarwal,

Have you tried the migration again? If so, and you’re still running into issues be sure to post back.

Hey @Montana,

Tried again now. Unfortunately, I am still facing the same issue.

Same here. Single repo migration or bulk returns a 500 response from the API: POST https://api.travis-ci.com/repo/4456537/migrate 500

{
  "@type": "error",
  "error_type": "error",
  "error_message": "There was a problem with migrating a repository. Please contact Travis CI support for more information"
}

Accidently merged a failing PR as checks weren’t showing up, so went and migrated all of my remaining repos still on the legacy .org and now stuck unable to migrate and unable to see status checks on GitHub.

Also stuck here: https://travis-ci.com/github/SciTools/cartopy

Hit Migrate and it changes to Migrating…, but then nothing happens.

2 Likes

Same problem for:


and

but not:

  • same 500 response error

Adding my voice here. The /migrate endpoint for my repo is returning a 500 error as well as seen in Chrome Devtools Network tab. The site fails silently and shows no error.

https://api.travis-ci.com/repo/13861594/migrate

Hi @montana,

Is it possible to request someone from Travis to manually do the migration? Currently, Travis isn’t running on any of the Pull Requests :worried:.

Our release is also handled by Travis and we are stuck because of this issue.

Thanks,
Abhinay

Same issue with https://travis-ci.com/github/ionaru/easy-markdown-editor. The page returns back to its initial stage after a few minutes.

Migrating from the settings page does not appear to be working either, when I hit ‘migrate’ in the pop-up, the pop-up closes and nothing happens. When I navigate to https://travis-ci.com/github/ionaru/create-package it does not show it is doing a migration.

1 Like

Hi, I’m expereiencing the same issue with https://travis-ci.com/github/mapaction/mapactionpy_controller and https://travis-ci.com/github/mapaction/mapactionpy_arcmap

I have also tried manually triggering a build, but I got an error message “Oh no! Oops, something went wrong, please try again.”
image

Also experiencing the same problem: 500 error when I try to migrate a repo from .org to .com.

me too.

I’m experiencing the same issue with https://travis-ci.com/github/undertheseanlp/underthesea.

same issue here:
https://travis-ci.com/github/qgymib/EAF

Today, this issue is fixed. Now I can migrate my repo.

Thanks

I can confirm that the issue is resolved for me. Migration successful. Hurray!

Imprint