Build not getting triggered

The repo is https://travis-ci.org/github/apache/druid
Seems like since around 11 hours ago, non of the build are getting triggered.
PR commits still show up on Travis page but non of the build for the PR is starting.
Seems very weird as some PR are stuck for more than 11 hours. (such as https://github.com/apache/druid/pull/9725 has last commit pushed 10 hours ago)

The apache organization is huge. It runs a lot of jobs (e.g., at the moment, https://travis-ci.org/apache/kylin/jobs/677237970 https://travis-ci.org/apache/flink/jobs/676955592). Your build will run in time. Please wait.

I have a followup questions that indicates there might be something wrong with Travis
The link you provided (https://travis-ci.org/github/apache/flink/builds/676955554) indicates that there are some jobs taking more than 50 minutes (from 2 hours to 6.5 hours). For example,

e2e - misc - hadoop 2.8
1 hr 53 min 43 sec

and
connectors - hadoop 2.4.1
6 hrs 36 min 37 sec

I thought there is a 50 mins timeout?

Certain repositories have special limits.

I am not sure if this is related to the slowness of jobs being triggered (not sure if it is just a number/reporting bug vs. if the jobs actually caused the build to be occupied for the 6.5 hours).
But regarding the 6.5 hours that is shown on the Travis build page, I think that is unusual.

  1. I also notice 6.5 hours in https://travis-ci.org/github/apache/druid for https://travis-ci.org/github/apache/druid/jobs/677181051 (I know for a fact that the apache/druid has timeout of 50 minutes)
  2. The connectors - hadoop 2.4.1 in apache/flink usual runs for ~40 mins (https://travis-ci.org/github/apache/flink/jobs/676892583). It is very weird for 6.5 hours as indicated in the link you sent (https://travis-ci.org/github/apache/flink/jobs/676955561)
Imprint