Build config file required... config is empty. Help

I have a private GitHub repo and Codename One project that I’m trying to get Travis CI Pro working with.

I’ve added the Travis config files that are automatically generated with Codename One, I’ve given Travis complete access to the repo on GitHub, and I’ve added the repo to Travis, but there is no toggle next to it where all the instructions keep telling me to turn on to select it.

In the repo under the Current tab it says that there are no builds for this repository. Under the Branches tab it says no other branches for this repository, even though there are two branches in GitHub.

If I go to More options > Requests it shows all the commits, but they’re all failed as job rejected. The error is "Build config file is required via repository settings, but config is empty. My GitHub has the .travis.yml file.

Any help would be much appreciated, thanks.

edit: I should mention I’m using eclipse oxygen and a Travis Education account

1 Like

Sounds like your .travis.yml is invalid (probably some syntax error). Use validators such as https://yaml-online-parser.appspot.com to review it, please.

2 Likes

I copied my .travis.yml file into the suggested link. The output is:

{
  "matrix": {
    "include": [
      {
        "before_script": [
          "export DISPLAY=:99.0", 
          "sh -e /etc/init.d/xvfb start"
        ], 
        "language": "java", 
        "env": "CN1_PLATFORM=javase CN1_RUNTESTS_JAVASE=1", 
        "jdk": "oraclejdk8"
      }
    ]
  }, 
  "env": {
    "global": null
  }, 
  "script": [
    "bash .travis/build.sh;"
  ]
}
1 Like

Interesting. Please include the requests page’s URL where you see the requests rejected. Thanks.

2 Likes

https://travis-ci.com/kiwiFudge/GDG-v1.0/requests

Thank you for looking into this for me :slight_smile:

1 Like

Hmmm. Do you have a file named .travis.yml in the repository root? (The repo is private, so I cannot confirm it.)

2 Likes

The .travis.yml file is in the root directory of the repo, yes.

Sorry, I cannot make this repository public. I’m happy to provide the information you need as we work through this problem if I am able however.

1 Like

This is what my Travis repository page looks like:
image

From everything I’ve seen online there is suppose to be a toggle for a repo to recognise any changes, but it’s not displayed for mine. Any way to fix this issue?

Still unresolved issue. Any more insight?

Hey there,

Is there any chance you could upload (or copy-paste) the full .yml file here? If not, I’d suggest you’d email our support team so they can assist you privately. :smile: support@travis-ci.com

Generally, this error is when the file isn’t quite parsed correctly, and it can be very specific with formatting.

Can’t upload the file to this thread, but here’s the link for a google drive upload of the .travis.yml file. This is the default file that Codename One installs.

Side note: the file downloads without the leading dot.

Thanks!

I tried it in one of my test repos and it worked just fine. :confused: Looks like there’s definitely something odd happening there.

As it’s for a private repo, I’d say it’s best to bring it up to support@travis-ci.com so our support team can assist you with it better. All the best and happy building!

Thanks for looking at it.

Just as a side question, I don’t suppose you would know much about Codename One (I might ask CN1 as well), but does the build.xml need to remain unchanged for Travis to recognise the project?

Hm, no, I don’t see how that would affect things on our end, but I can’t say I’m too familiar with Codename One, no. Sorry!

Imprint