All connections to travis-ci.com fail

Hi.

I unfortunately dont have a link to an issue, mainly because I cannot seem to access travis-ci.com in any way.

Trying to open travis-ci.com for me just has me forever handing with the loading avatars, in three different browsers, with cache cleared and even in incognito mode. I’ve also tried accessing travis via command line and get

Timeout was reached: [api.travis-ci.com] Connection timed out after 10000 milliseconds

I can even seem to access the build svg for my gihub readme file

HttpExceptionRequest Request { host = "travis-ci.com" port = 443 secure = True requestHeaders = [] path = "/LCBC-UiO/ggseg.svg" queryString = "?branch=master" method = "GET" proxy = Nothing rawBody = False redirectCount = 10 responseTimeout = ResponseTimeoutDefault requestVersion = HTTP/1.1 } ConnectionTimeout

Any help is appreciated to understand why I cant seem to get in.

WFM. Must be network issues for you. Have your provider or sysadmin check the routing and/or filtering.

You can use the https://downforeveryoneorjustme.com/ online service to check if a connectivity problem is local for you or not.

1 Like

Thank you. That webpage is genius!

Ok. This is my home network so there should be nothing I’ve done personally for this to happen, so I’ll contact my provider and see if there is something happening.

Thank you for taking the time.

Example for other people:
It is still possible a laptop issue.
If I use mobile phone with 4G or home wifi: virtualbox.com is site available

But my work laptop won’t connect to virtualbox.com via:

  • home network
  • home network + VPN
  • work office network

Because it is block in my laptop by my IT department.

So also always try to use mobile + local home wifi to isolate the connection problem.
If it work then it must be a laptop issue.

I’ve done numerous tests now, neither provider nor I understand what is happening.

What seems to happen is that once I clear all cache, cookies and history, I can atleast access travis-ci.com and see the initial page. I can also navigate around, without signing in, information about travis on the different pages.

The trouble arises once I try to log in using my github account. so it’s actually api.travis-ci.com that is stalling everything.

I’ll keep trying to understand, but I have a current work-around logging into a remote computer at work and checking there.

Are you using an ad blocker? That could explain browser malfunctions.

Double checked ad blockers now, there should be none. Tested on Safari, Firefox (newly installed just to test this), and chrome (with all data deleted and incognito).

If it works at another computer, I can suggest cleaning up your browser’s profile (delete all cookies, extensions, history etc – there’s likely to be such an option somewhere in your browser’s UI). To rule out cookies, you can also try the actions in the browser’s “private mode”.

If you are using some network customizations (proxy, VPN), they may be interfering, too. Besides an ad blocker, other browser extensions may be altering pages as well.

To say anything else, I must see your browser’s network activity when the problem happens (e.g. Firefox’s built-in devtools can save it as a HAR) and the exact reproduction steps.

Hi @native-api. I’ve tried all the steps you suggest, and I’m using no proxy or VPN.

I made a HAR using firefox (never made one before so hope its correct).
Steps I did was:

  1. go to travis-ci.com (here everything worked fine)
  2. click sign-in (again everything worked fine)
  3. sign-in with github (resulted in constant loading and is when I made the HAR)

Thank you for helping

Imprint