Windows build failed, actually it was done success


#1

I tried to build my own project, the .travis file is here.
When I saw the log (it was too long because npm i --loglevel verbose), the last few line was.

travis_time:end:1040a3c9:start=1541124571037223400,finish=1541124576085814800,duration=5048591400
e[0Ktravis_fold:end:dpl_0
e[0Ktravis_time:start:0011be30
e[0Kinvalid options: -SHN
(invalid options are ignored)
Successfully installed multipart-post-2.0.0
Successfully installed faraday-0.15.3
Successfully installed public_suffix-3.0.3
Successfully installed addressable-2.5.2
Successfully installed sawyer-0.8.1
Successfully installed octokit-4.6.2
Successfully installed mime-types-2.99.3
Successfully installed dpl-releases-1.10.4
Parsing documentation for multipart-post-2.0.0
Installing ri documentation for multipart-post-2.0.0
Parsing documentation for faraday-0.15.3
Installing ri documentation for faraday-0.15.3
Parsing documentation for public_suffix-3.0.3
Installing ri documentation for public_suffix-3.0.3
Parsing documentation for addressable-2.5.2
Installing ri documentation for addressable-2.5.2
Parsing documentation for sawyer-0.8.1
Installing ri documentation for sawyer-0.8.1
Parsing documentation for octokit-4.6.2
Installing ri documentation for octokit-4.6.2
Parsing documentation for mime-types-2.99.3
Installing ri documentation for mime-types-2.99.3
Parsing documentation for dpl-releases-1.10.4
Installing ri documentation for dpl-releases-1.10.4
Done installing documentation for multipart-post, faraday, public_suffix, addressable, sawyer, octokit, mime-types, dpl-releases after 14 seconds
8 gems installed
travis_fold:start:dpl.1
e[33mInstalling deploy dependenciese[0m
The system cannot find the path specified.
The system cannot find the path specified.
Logged in as liudonghua
Deploying to repo: liudonghua123/system-network-info
Current tag is: v0.1.1

travis_fold:end:dpl.1
travis_fold:start:dpl.2
e[33mPreparing deploye[0m

travis_fold:end:dpl.2
travis_fold:start:dpl.3
e[33mDeploying applicatione[0m

travis_fold:end:dpl.3
travis_time:end:0011be30:start=1541124576183453900,finish=1541124612883645600,duration=36700191700
e[0K
Done. Your build exited with 0.


No output has been received in the last 10m0s, this potentially indicates a stalled build or something wrong with the build itself.
Check the details on how to adjust your build configuration on: https://docs.travis-ci.com/user/common-build-problems/#Build-times-out-because-no-output-was-received

The build has been terminated

The full logs were here


Location of Python install for Node
#2

This seems to happen for every successful run of Node.js on Windows. Here is my output: https://travis-ci.org/SimenB/weak-travis-windows/jobs/454230820


#3

Your build has a process running and it is not getting cleaned up.


#4

@BanzaiMan thanks! I missed that issue previously. It looks like a duplicate of this one and the fix there solved my issue.