Build doesn't finish after completing tests

Looks like this:

Done. Your build exited with 0.
No output has been received in the last 10m0s, this potentially indicates a stalled build or something wrong with the build itself.

https://travis-ci.org/thelounge/thelounge/jobs/440606641
https://travis-ci.org/thelounge/thelounge/jobs/440339972

This doesn’t happen on linux or osx builds.

Do you start some sort of subprocess in the background during your tests? If so, Windows might need extra nudge cleaning up these processes in order to exit the build cleanly.

I don’t think we do.

I also develop on Windows myself, and running tests exists cleanly.

same issue here:
https://travis-ci.com/AviVahl/ts-tools/builds/87770857

using yarn & lerna. works on linux/osx. windows is stuck.
might also be worth noting same repo works on appveyor.

thx for the great feature! would love to only use a single CI.

@AviVahl Do you start gpg-tools? This is what I see when I just add ps -ef after your build ends:

https://staging.travis-ci.com/BanzaiMan/ts-tools/jobs/232474#L254

We should probably clean up child processes of the build script after the build for better UX.

I just did ps -ef on our build, and we have gpg-agent in there too. I am quite certain that we don’t use it though.

https://travis-ci.org/thelounge/thelounge/jobs/440769451#L221

Does it automatically start on the build machine (perhaps after running yarn?)

EDIT: This post was marked as spam?

My guess is the yarn installation:

before_install:
  - curl -o- -L https://yarnpkg.com/install.sh | bash -s -- --version 1.10.1
  - export PATH=$HOME/.yarn/bin:$PATH

their install.sh uses gpg.

The above config is the one suggested by the Travis docs for custom yarn version.

Checked it without my before_install. Still got stuck. It appears the yarn installation (and pgp verification) occurs anyway, because my repo contains a yarn.lock.

The repo is setup using yarn workspaces, so I have no proper matching alternative in npm land yet. :frowning:

EDIT:
tried setting env variable YARN_GPG=no (via travis’s configuration) to force no gpg validation, but the container appears to be stuck on: Worker information

1 Like

I’ve used secure env tokens (via Travis config- “hide from log”), which seems to be broken with Windows containers. Trying regular env var to see if behavior is different.

EDIT:
Yes! It was the gpg that install.sh of yarn runs. Build now passes, after setting the YARN_GPG=no environment variable.

1 Like

Sorry about that - I think I’ve fixed it, but please let us know if it happens again. Thanks!

1 Like

Similar problem here, but my builds are hanging after failing

https://travis-ci.org/chrisdothtml/hey/builds/443190221

Hi @chrisdothtml

Could you please try adding YARN_GPG=no to your .travis.yml config to see if this helps?

@BanzaiMan do we currently detect and kill rogue processes when a build finishes?

1 Like

@josh Tried that. New error this time

https://travis-ci.org/chrisdothtml/hey/jobs/444241108

@chrisdothtml I’ve seen this time to time, can you restart to see if the issue persists?

@josh yep, looks like restarting the build resolved it. Thanks!

Fantastic to hear!

I will add this issue to one we should address long term.

@josh i encountered the original ‘all fine but dont finishing’ today. and also the fix with YARN_GPG=no worked.
is there a bug that i can track?

and by the way -
is there any option to set YARN_GPG only on windows builds?

sunny greetings
stefan

This happens again. 2 different projects never finish the Windows builds.

Same issue here. Windows builds do not terminate. https://travis-ci.org/DanySK/jirf/builds/554123269

OK, in my case was the Gradle daemon hanging the build. I was able to configure the build for Java / Gradle via Jabba. It’s been kind of a hell though.

1 Like
Imprint