Upgrade MacOS environment to a supported release

Due to MacOS 10.11 El Capitan is EOL; brew has dropped official support , Homebrew no longer provides bottles for MacOS 10.11, so one has to build them from source which takes a LOT of time.

E.g. for ffmpeg, building it and all dependencies takes three times the Travis job limit (and we still need time to build our project proper after that).

Use a different osx_image value. https://docs.travis-ci.com/user/reference/osx#macos-version

Damn, I keep forgetting that!
Thanks.

Imprint