Updated package.json and .babelrc ignored


#1

Hi,

I found that travis ignored the updated package.json changed included .babelrc. I tried to flush cache and change package.json version but nothing worked.

To quick fix, I added logic to delete package.json and .babelrc after that download updated files from Github repo: https://github.com/impress-org/give/blob/release/2.4.2/tests/e2e/bin/install.sh#L18

Let me know if this an issue with travis or I am missing any configuration.


#2

Please point to a relevant build log URL and explain:

  • What you expected to happen
  • What actually happened

Thanks.


#3

@BanzaiMan

https://travis-ci.org/ravinderk/Give/builds/503066689

I expected package.json with verison 2.4.2 and updated .babelrc in build to run jest successfully. As you can see in commit both files was updated https://github.com/ravinderk/Give/commit/a5c2be0eeeb7fd30ebbf348dd834ff176ddc32c7

Let me know if you need any more details


#4

In


You are cloning https://github.com/impress-org/give.git into ~/wordpress_data/wp-content/plugins/give/ and looking at its package.json, not your repo’s.

I can’t tell you how you want to fix it, but this is expected behavior as you defined it.