Unable to upload package to PyPI

I’m working with OctaByte and we start the new project FireO

I’m trying to setp Travis to automatically publish package to PyPI.
But don’t know what is the problem I tried to configure and it’s not able to upload the package and Log are not clear info to understand the problem.
Project code is hosted in Github FireO

Here I have some logs that shown in my travis console log

rvm (travis_internal_ruby) --fuzzy do ruby -S gem install dpl

dpl.1

Installing deploy dependencies

dpl.2

Preparing deploy

dpl.3

Deploying application

src/fireo.egg-info/PKG-INFO already exists, no checkout

src/fireo.egg-info/SOURCES.txt already exists, no checkout

src/fireo.egg-info/dependency_links.txt already exists, no checkout

src/fireo.egg-info/top_level.txt already exists, no checkout

Could not restore untracked files from stash entry

PyPI upload failed.

failed to deploy

Please link to a build showcasing the problem. Copypasting things here gives incomplete information.

https://travis-ci.org/octabytes/FireO/builds/591372431#L342

We don’t actually authenticate in this case; it is a confirmation that we have both user name and decrypted password at that point. And they were rejected by PyPI.

I have some special character in my password escape them by slash(\) after that I tried to enter password from stdin and it’s working

Imprint