"Unable to load dynamic library ‘apcu.so’" error on PHP 8/nightly

Hi!

When i try to test PHP 8.0 or nightly or 8.0snapshot, i get the following error.
Also, when i try to install apcu extension, it warns that it is already installed.
PHP 7.3 and 7.4 works great!
Btw all unit tests passed on local machine.

Do you have an idea about the solution?
Should we wait a little longer for PHP 8?

Error Output

Warning: PHP Startup: Unable to load dynamic library ‘apcu.so’ (tried: /home/travis/.phpenv/versions/8.0.0/lib/php/extensions/no-debug-zts-20200930/apcu.so (/home/travis/.phpenv/versions/8.0.0/lib/php/extensions/no-debug-zts-20200930/apcu.so: cannot open shared object file: No such file or directory), /home/travis/.phpenv/versions/8.0.0/lib/php/extensions/no-debug-zts

Related Job

Hey @afbora,

I looked over the documentation it obviously works with PHP7, I’ll ask internally and see if I can’t get you an answer.

This link could also be a help to you:

Thank you @Montana. I would be very pleased.

After digging a bit, I found this build by krakjoe, (same repo I pointed you to) and it seems this person has apcu.so working on nightly and 8.0snapshot. I would suggest going over their .travis.yml to see if there’s anything you missed out.

If that doesn’t work, please let me know.

Thank you so much for digging @Montana

We have already started testing as PHP 8.0snapshot. It was working initially. Then suddenly it started giving this error.

Here PHP 8.0snapshot job on forked repo

PHP 8.0snapshot was working few days ago and here the job:

Please see this:

If the snapshot was working before, it should continue to work, by the way.

Thanks for reply @BanzaiMan Now is that fixed? I’m asking because your last commit test failed.

Sorry about the continued problem. I’m still working on fixing it.

1 Like

OK, I’ve addressed the issues that I know of. Could you try again and report the result?

1 Like

The test is now complete. Here the job results:

Does php: 8.0.0 exhibit the same problem?

You right, the test passed on PHP 8.0.0

OK. I think we’ll just have to copy 8.0.0 archives to 8.0, so that’s a lot simpler. Sorry for the continued problem, but I think we are almost there.

That should be done now. php: 8.0 should also work.

I have restart the last build. Now PHP 8.0 gives a different error while others continue to fail. 8.0.0 is still passed. Am I missing something?

I ran the new build to make sure the result is the same:

Oh, I see now. The 8.0 archive isn’t quite the same as the 8.0.0 archive. I’ll have to look at it again next week.

Please use 8.0.0 in the meantime.

1 Like

I’m grateful for your support. Thank you.

@BanzaiMan recreated the 8.0 archive and works great now. Thanks!

1 Like

As for “nightly”:

Travis CI can test your PHP applications with a nightly PHP build, which includes PHPUnit and Composer, but does not include third-party PHP extensions:

Imprint