Travis won't build nor see new commits or pull requests

Hi there!

New to posting here. I have set up Travis CI in a new repo I created not long ago and everything was fine until a couple of days ago. Travis created the builds whenever I uploaded new commits or pull requests. However, now it seems like it won’t build again.

Initially, this repo was apparently hosted on travis-ci.org. When I got the error, I looked up on the internet for a solution but nothing came out to solve it. I don’t know how but I managed to migrate the repo to travis-ci.com (don’t quite understand the difference between those). However, it was useless. Everything seems fine and Travis won’t even see new commits or u updates to the repo.

On top of that, I tried to trigger the builds manually through the webpage of the repo. When I try to do so, I am prompted a message saying: Hold tight! Your build was created successfully. It might take some minutes to show up or something alike, but I don’t see changes whatsoever.

Here is the .travis.yml config file just in case it helps:

language: node_js
node_js:
  - 12.18.0
cache:
  directories:
    - node_modules
before_install:
  - sudo apt-get update
  - sudo apt-get -y install ruby openjdk-8-jre
before_script:
  - export NODE_OPTIONS=--max_old_space_size=8192
script:
  - npm install -g codecov
  - codecov
  - npm run build
deploy:
  provider: pages
  skip_cleanup: true
  github_token: $TOKEN
  local_dir: build
  on:
    branch: master

I am creating a new thread because I couldn’t find anything that helped me even understand what is happening. If someone could give some hint on what could be the problem, it would be really appreciated. I am sorry if I didn’t provide enough information on the problem, there is not much that I can grasp.

Thanks in advance!!

Hello, there. Could you point to the repository’s URL which is having a problem? Also, there is a “Requests” item in the “More options” drop-down menu which might give you clues as to why.

Thanks for your reply!

This is the URL of the repo: https://github.com/SmallDreamDev/small-dream-servidor.

I tried that already… I’m afraid that images are not welcome in these forums but it might be faster to explain with an image:

I have almost 10 of those tries to rebuild by my manual trigger through the GUI. I don’t understand what happens after I trigger a manual build because I don’t see any major change in this tab other than a new line like the one in the image.

Could you push a commit to this repository, instead of triggering an API build?

I have tried that a couple times but nothing seems to happen. I will push a new one and link it here so you can see it.

Here is the new commit to master: https://github.com/SmallDreamDev/small-dream-servidor/commit/d7ccbedbc8f2686286fd13f05da411a689622714

There is no change in travis repo’s dashboard

Hmmm. Could you try disabling and re-enabling GitHub Apps?

https://travis-ci.com/account/repositories

Indeed you were right!

It seems like we had travis contributor suspended for no reason from the control panel of the organisation. Just had to click “Unsuspend” on the travis CI configuration.

Seems like I didn’t look deep enough. It is now building new commits and pull requests.

Thank you very much! :smile:

1 Like

Sweet. Happy to hear that you were able to overcome the problem.

Can you tell me where this button is?
I can’t find it.
Thanks in advance!

Imprint