TRAVIS_BUILD_STAGE_NAME isn't capitalized

In @votca we found that since a month ago TRAVIS_BUILD_STAGE_NAME wasn’t capitalized anymore, even though the documentation says so.

Workaround for @votca: votca/votca#271

Also reported here: mlflow/mlflow#2631
And reported as: https://github.com/travis-ci/travis-ci/issues/10512

2 Likes

3 posts were split to a new topic: Build config validation causes stage names to become uncapitalized

Default Environment Variables Documentation says:
" TRAVIS_BUILD_STAGE_NAME : The build stage in capitalized form, e.g. Test or Deploy . If a build does not use build stages, this variable is empty ( "" )."

1 Like

Hello, everyone.

We’ve discussed this internally, and we would like to move forward with not touching the stage names, and update the documents accordingly.

We understand the problems this has caused, but we also feel that this is a more logical behavior.

Thank you for your understanding.

1 Like

Are there certain scenarios where the stage names would still be automatically capitalized? I’ve noticed that in some repos/builds they are not, whereas other they are? It is at all related to whether the “Enable build config validation” flag is turned on?

Thanks for the reply. I’m unsure what you mean by “not touching the stage names”. Currently, the stage name will be capitalized when build config validation is disabled, and lowercase when build config validation is enabled. Do you mean that behavior will be preserved?

Imprint