Build config validation causes stage names to become uncapitalized

I’ve encountered the same thing. Even more strange, “Test” and “Deploy” are capitalized for my project’s main repository, but not for my fork:

The true value of the variable ("Test or “test”) is shown right on the status page. Here it is for my fork:

Screen Shot 2020-04-23 at 13.03.41

And for the main repo you can see it is capitalized (I’m not allowed to post 2 images here, so I can screen capture and upload).

I believe the documentation is saying that it’s only capitalized when displayed in the UI, and the raw value should be in small letters. Since the stated purpose of this feature is: “so you don’t have to deal with uppercase strings in your .travis.yml file”.

So they actually fixed a bug rather than introduced it.

An inconsistent display reported by @rjollos, however, is a genuine UI bug.


@rjollos, I see that your fork has Build Config Validation enabled while the base project doesn’t. This may be what’s making the difference. Could you disable it and see if that changes things?

Yes, it looks like you are correct. With Build Config Validation enabled I get “test”. With it disabled I get “Test”.

Duplicate of TRAVIS_BUILD_STAGE_NAME isn't capitalized.

Imprint