Tests in Travis are not running

I trigger a build on my app but Travis doesn’t run any test. As suggested on Travis official doc, I have created a postgresql db before_script.

Here is my .travis.yml:

 language: python
python:
  - '3.7'    
before_script:
  - pip install -r requirements.txt    
env: DJANGO_SETTINGS_MODULE=my_app.settings.travis    
services:
  - postgresql    
before_script:
  - psql -c 'create database travis_ci_test;' -U postgres      
script:
  - ./My-App/manage.py test

And my Job log:

Setting environment variables from .travis.yml
$ export DJANGO_SETTINGS_MODULE=my_app.settings.travis
$ source ~/virtualenv/python3.7/bin/activate
$ python --version
Python 3.7.1
$ pip --version
pip 19.0.3 from /home/travis/virtualenv/python3.7.1/lib/python3.7/site-packages/pip (python 3.7)    
$ pip install -r requirements.txt    
$ psql -c 'create database travis_ci_test;' -U postgres
$ ./My-App/manage.py test

System check identified no issues (0 silenced).
----------------------------------------------------------------------
Ran 0 tests in 0.000s
OK
The command "./My-App/manage.py test" exited with 0.
Done. Your build exited with 0.

I have 9 tests running fine locally with python3 manage.py test . Do I have to ligrate first?

Any way you could post more of your .travis.yml file?

I fixed it. I had my travis.yml in the wrong folder

Glad you fixed it,

If you run into anymore problems please be sure to post back, and I’ll help you.

Imprint