Suddenly getting "Bundler::InstallError"


I’m suddenly seeing the following errors

Installing deployment dependencies
Installing gem dependencies: aws-sdk-cloudformation (~> 1.0)
bundler-2.5.0 requires ruby version >= 3.0.0, which is incompatible with the current version, 2.7.6 (Bundler::InstallError)

Below are the first few lines from my .travis.yml which hasn’t changed in ages:

language: node_js
dist: focal
  - 14

Managed to find a fix by using the below

language: node_js
  - 16

I’m getting the same error in two projects (node 14 and node 18)
Update the node version is not an option. Maybe the issue is on the focal dist…

We do have the same problem with node 20.
I think it’s related to the latest changes from yesterday:

Adding group: edge seems to fix the problem (as suggested by the support):

os: linux
dist: focal
group: edge

Hey everyone,

The current workaround has been marked.