Sonarcloud fails to authorize

During the build is executed analysys of the code through the sonarcloud. Suddenly sonar step started to fail with

ERROR: Error during SonarQube Scanner execution
ERROR: Not authorized. Please check the properties sonar.login and sonar.password.

example failing build
Tried to renew the sonar token with no luck. Any ideas on what might be the reason for this behavior?

1 Like

I can confirm that, multiple projects suddenly started failing:

We have the same issue.
My thread for this:
https://travis-ci.community/t/sonar-scanner-is-not-working-anymore/5848/2

There is a problem here: https://github.com/Ontotext-AD/graphdb-workbench/blob/3b88c8afbb211cffb4da687bad41f1c7c1c92e69/.travis.yml#L21

Which is a different manifestation of

which is explained in

So, in short: Check your secure values!

2 Likes

All is good but I still can’t get it running. Following this guide
I got the sonar token and encrypted it through this resource which I found in the apps listing. I didn’t use the travis CLI as I can’t get it running as well. Encrypted token I put in the .travis.yml

addons:
  sonarcloud:
    organization: "ontotext-ad"
    token:
      secure: "encrypted token here"

After this I still have the build failing due to the same ERROR: Not authorized. error.
Any Ideas on how can I proceed? Also is this site which I’m using for the encryption still relevant for the job or it’s outdated?

Imprint