Some Github projects don't show up

Gentlemen, I am a first-time user of Travis (or planning to become one) and I am starting with quite a strange problem:

I installed Travis to my Github account. In the repository configuration of Travis I selected All repositories. Now lots of my Github repositories show up. But hell, exactly that one repository I was planning to activate Travis for does NOT show up.

It is this repository:
https://github.com/verybadsoldier/backtrader_plotting

Also when not using All repositories but instead using Only selected repositories then I can select it but when returning back to the repository list of Travis (to configure) then it does not show up.

I googled alot already and read that I should try the Sync-button which I did but it didn’t help. I also waited several hours but still no luck.
Also I read that private repositories don’t show up either but that repo of mine isn’t private as far as I know.

Any ideas? I’m a bit out of luck. Thanks alot.

1 Like

Gentlemen and ladies,
I’m having the same problem. I added a repo a couple of days ago and it doesn’t show up in my list of repos in Travis (under “legacy services integration”). Clicking the sync button says “syncing from GitHub” but doesn’t appear to complete. Yet, reloading the page shows that the last sync occurred a few minutes ago, suggesting that the operation was successful.

All of my other repos appear to be present in the list, and usually newly added repos show up immediately, as far as I’ve been able to tell.

Any ideas? Were you able to get your issue resolved @vbs ?
Thanks,

I contacted Travis support, and this seems to be an issue with the migration from .org to .com. Sounds like all accounts are being consolidated in the .com domain, so for anyone else with this issue, you’ll need to give the .com permission to access your GitHub (same as you did originally for the .org). Once you’ve done that, the new repo should show up in your .com dashboard. You may additionally need to migrate existing .org repos to the .com domain, which you should be able to do via the settings in the .com dashboard.

Personally, I ran into another issue where, although the missing repo showed up in the .com dashboard, I was unable to migrate the existing repos that show up in my .org dashboard. So, for the moment, I will be using the .com for new repos, and the .org for my old repos. Travis support said they’re working on it, though, so hopefully it won’t be long before this will be fixed and I can use the .com dashboard exclusively.

1 Like
Imprint