SOLVED: Windows release deploy artifact missing in github after (apparent) successful windows job

#1

I’m attempting to use pyinstaller with os: windows to create a .exe file from a python script (on a pushed git tag). The build seems to work fine, the built .exe file is zipped into the ‘artifact’ subfolder and the job seems to finish successfully, but the artifact never ends up in the github release: https://travis-ci.org/tombech/sesam-py/jobs/512494774

The linux and osx artifacts jobs work as expected (but use tarballs instead).

I’m fairly new to travis, am I doing something obviously wrong here? I’ve looked at the known issues topic but can’t see a matching issue there.

(the .travis.yml is probably a bit messy due to trying various thing to make it work: https://github.com/tombech/sesam-py/blob/master/.travis.yml)

#2

My initial guess is that on Windows, $TRAVIS_BUILD_DIR is not properly resolved by Ruby.

So there is no file to upload. If you are certain that you are in $TRAVIS_BUILD_DIR during the deployment, perhaps dropping it from the file value would result in successful upload.

No windows asset file found after deploy to Github release success
#3

Thanks! That seems indeed to be the problem. Removing “$TRAVIS_BUILD_DIR” from the deploy config worked for me.