[SOLVED] Deploy phase not firing

I’ve been fiddling with this for an embarrassingly long time. There has to be something I’m missing, but I just can’t see it. I have a staged build. The deploy stage is firing as expected, as are most of its phases, but not the deploy phase. Any idea why?

  - name: build
  - name: publish
    if: (type == push && branch == rob-release-and-deploy) || tag IS present
  - name: deploy
    if: (type == push && branch == rob-release-and-deploy) || tag IS present
  - name: clean

# ... Other bits until we hit the deploy stage of jobs: include: ...

    - stage: deploy
      name: "Deploy to dev|aut|stg"
        - curl -LO https://storage.googleapis.com/kubernetes-release/release/v1.23.6/bin/linux/amd64/kubectl
        - chmod +x ./kubectl
        - mv ./kubectl ${HOME}/.local/bin
        - echo "Placeholder?"
        - aws ecr get-login-password --region "${AWS_REGION}" | docker login --username AWS --password-stdin "${AWS_ECR_REGISTRY_URL}/tmp"
        - provider: script
          script: "bash ./bin/deploy dev"
          skip_cleanup: true
            branch: rob-release-and-deploy
        - provider: script
          script: "bash ./bin/deploy aut"
          skip_cleanup: true
            condition: tag IS present && (tag =~ /^\d{8}\.rc\d+$/)

At this point, I’m committing code to the rob-release-and-deploy branch (a PR open on that branch). There’s no indication that the deploy: phase is being recognized at all. It’s not being skipped with the message I might normally see if I were pushing to a different branch or something…it’s simply not doing anything at all. The build succeeds after the script phase.

The last bit of the build stage output looks like this:

0.00s$ echo "Placeholder?"
190The command "echo "Placeholder?"" exited with 0.
192travis_run_after_success: command not found
193travis_run_after_failure: command not found
194travis_run_after_script: command not found
195travis_run_finish: command not found
197Done. Your build exited with 0.

I could really use another set of eyes on this.

Solved. In my second deploy target, i need to specify tags: true:

        - provider: script
          script: "bash ./bin/deploy aut"
          skip_cleanup: true
            tags: true
            condition: tag =~ /^\d{8}\.rc\d+$/