Snap deployment stopped working out of nowhere

Out of nowhere snap deployment stopped working:
https://travis-ci.org/johannesjo/super-productivity/jobs/638109475

Before:
https://travis-ci.org/johannesjo/super-productivity/jobs/635454661

The error shown is:

    /home/travis/.rvm/rubies/ruby-2.4.5/lib/ruby/2.4.0/open3.rb:199:in `spawn': No such file or directory - snapcraft (Errno::ENOENT)
        from /home/travis/.rvm/rubies/ruby-2.4.5/lib/ruby/2.4.0/open3.rb:199:in `popen_run'
        from /home/travis/.rvm/rubies/ruby-2.4.5/lib/ruby/2.4.0/open3.rb:95:in `popen3'
        from /home/travis/.rvm/rubies/ruby-2.4.5/lib/ruby/2.4.0/open3.rb:258:in `capture3'
        from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-snap-1.10.14/lib/dpl/provider/snap.rb:32:in `check_auth'
        from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.14/lib/dpl/provider.rb:187:in `block in deploy'
        from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.14/lib/dpl/cli.rb:41:in `fold'
        from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.14/lib/dpl/provider.rb:186:in `deploy'
        from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.14/lib/dpl/cli.rb:32:in `run'
        from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.14/lib/dpl/cli.rb:7:in `run'
        from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.14/bin/dpl:5:in `<top (required)>'
        from /home/travis/.rvm/gems/ruby-2.4.5/bin/dpl:23:in `load'
        from /home/travis/.rvm/gems/ruby-2.4.5/bin/dpl:23:in `<main>'
    failed to deploy

I suspect this is due to an updated snapcraft, which may require an update to snapd. See

You can try this fix by testing the prerelease (see https://blog.travis-ci.com/2019-08-27-deployment-tooling-dpl-v2-preview-release for more details) with:

deploy:
  edge: true
  # ⋮ rest

or updating snapd yourself:

before_deploy:
  - sudo apt-get update -qq
  - sudo apt-get install snapd
deploy:
  edge: true

Is indeed fixing the problem. Thank you!

Imprint