Pypi deploy fails for Python 2.7

I have a Pypi deploy job for Python 2.7. It used to work fine, but today it fails due to get-pip.py.

My deploy code is

deploy:
  - provider: pypi
    user: $PYPI_USER
    password: $PYPI_PASSWORD
    on:
      all_branches: true
      tags: true
      python: 2.7
    skip_cleanup: true

And the error is

Successfully installed dpl-pypi-1.10.16

1 gem installed

2021-06-02 07:31:50 URL:https://bootstrap.pypa.io/get-pip.py [1937800/1937800] -> "-" [1]

ERROR: This script does not work on Python 2.7 The minimum supported Python version is 3.6. Please use https://bootstrap.pypa.io/pip/2.7/get-pip.py instead.

Couldn't install pip, setuptools, twine or wheel.

failed to deploy

Is there any way to ask Travis to download get-pip.py from Python 2.7 URL?

1 Like

What dist are you using? Try changing to focal via:

dist: focal

I did not specify a dist, but it still failed, after I change the dist to focal today.

My failed job link is 510627538

@Montana My CI job has 3 Python versions, 2.7, 3.5 and 3.6, and it only deploy Python 2.7 artifacts. 3.5 and 3.6 are only for compatibility test.

My .travis.yml

Did you ever get this to work? I am running into the same issue.

I use this workaround to make it work. https://github.com/travis-ci/dpl/issues/1235

My code change is https://github.com/F5Networks/f5-common-python/pull/1590/files

Still doesn’t work for me unfortunately, on Python 3.5. Same error as before. Meanwhile, Python 2.7 complains about having to install python3-vevn via apt, but doing so fails as it can’t find it.

I am surprised this isn’t a more common issue, as this thread and the GitHub issues are all I can find about it and neither has fixed it for me. I’m running a pretty vanilla setup I feel like.

Imprint