Pushing tag does not trigger deployment to github releases

#1

Hi, I want to deploy a release on github every time I push a tag on master. I set up the relevant deploy parts in .travis.yml, but whenever I push a tag using:

git tag -a v0.1.0.check_deploy
git push --tags

Nothing noticeable happens. I checked the build list but couldn’t find any new builds. This problem is very difficult for me to debug because I can’t find any logs that explain what happens (or what doesn’t happen).

I also tried to open test branches and put tags on those branches, but no luck there too: nothing noticeable happens.

The repository (freedomlayer/offst) moved at some point to travis-ci.com, although it is a public repository. Could this be related to the issue?

My .travis.yml file could be found here. I include here what I believe to be the relevant part, but I might be wrong, and it could be that something else in the .travis.yml file causes the issue.

before_deploy: travis/before_deploy.sh
deploy:
  provider: releases
  api_key:
    secure: [omitted]
  file: $HOME/deployment/${PROJECT_NAME}-${TRAVIS_TAG}-${TARGET}.tar.gz
  skip_cleanup: true
  on:
    tags: true
    repo: freedomlayer/offst
    branch: master
branches:
  only:
    # Pushes and PR to the master branch
    - master
    # Ruby regex to match tags. Required, or travis won't trigger deploys when
    # a new tag is pushed. Version tags should be of the form: v0.1.0
- /^v\d+\.\d+\.\d+.*$/

Any help is appreciated!

#2

Sorry for the troubles you are running into!

Looking at your latest build requests it seems “push” builds are disabled on your repository which might explain the issue here.

Could you try to re-enable them in your repository settings and push a new tag to see if it helps?

1 Like
#3

@dominic: Thanks, it worked! I think I would have never came up with that solution myself.
What an adventure, I dedicate you my first ever travis release: https://github.com/freedomlayer/offst/releases/

1 Like
#4

Glad to hear it, @realcr, and thanks for the honor!

closed #5