PostgreSQL `type "jsonb" does not exist`


#1

One of the builds in question

Per the build system information, the PostgreSQL version used in this specific build is 9.6.6.

When running migrations, I run into the issue type "jsonb" does not exist. It certainly does exist in 9.6.

Regardless, I tried pinning a higher version, and ran into further issues; specifically it appears postgres doesn’t start at all. Is this something that must be done manually? The documentation doesn’t indicate such.

Any help would be appreciated, as the tests run as expected on my machine, but fail the second it hits Travis.

Pinging @BanzaiMan, who suggested I post here.


#2

I think there is something of a mismatch here, between what the information tells you and what your build is actually running. That is to say, the former shows you 9.6 (because it is the version we used when we collected the information on the build image), but the default PostgreSQL server version running when a Trusty image boots up is 9.2.x.

Please consult https://docs.travis-ci.com/user/database-setup/#using-a-different-postgresql-version for how to start a 9.6 server instead.


#3

You have a typo.


#4

Hmm, certainly seems like the info provided should be changed or hidden if it’s not necessarily accurate.

Not sure how I missed the typo — will certainly give that a shot. If it works them I’m happy; just wish the IDE could tell me that :stuck_out_tongue:

Thanks!