Port 10010 is used by docker-containerd

I’m trying to upgrade from precise to xenial, but unfortunately I found out that on the new environment, the port 10010 is bound by docker-containerd and this is causing failures in the unit tests, since my software at some point is trying to bind to that port. Obviously I can change the port, but I think I shouldn’t be forced to change the behavior of my software because of the testing environment…

On the build machine:

docker version
Client:
 Version:           18.06.0-ce
 API version:       1.38
 Go version:        go1.10.3
 Git commit:        0ffa825
 Built:             Wed Jul 18 19:11:02 2018
 OS/Arch:           linux/amd64
 Experimental:      false
Server:
 Engine:
  Version:          18.06.0-ce
  API version:      1.38 (minimum version 1.12)
  Go version:       go1.10.3
  Git commit:       0ffa825
  Built:            Wed Jul 18 19:09:05 2018
  OS/Arch:          linux/amd64
  Experimental:     false

.

$ sudo netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1675/sshd       
tcp        0      0 10.20.0.191:10010       0.0.0.0:*               LISTEN      3247/docker-contain
tcp6       0      0 :::22                   :::*                    LISTEN      1675/sshd       
udp        0      0 0.0.0.0:68              0.0.0.0:*                           909/dhclient    

This is all the information I could find:




I hope this helps…

Cheers,
Daniele

Confirmed. docker.service is running by default in xenial while the docs say it shouldn’t.

Thanks for the report.

Please consider shutting down the docker service or changing the test port. We are working on getting the next generation of build images, and it may take a while for the old images to get updates (even if it’s just to disable the service).

Thanks again.

Thanks! I’m not a docker expert, can you give me a hint on how to shut down the service?

sudo service docker stop should do the job.

Thanks! For reference, this worked:

if [ "$TRAVIS_OS_NAME" == "linux" ]; then sudo service docker stop; fi

@BanzaiMan Apparently, the issue is still present also on bionic images…

Imprint