"pip install" does not work everytime in Trusty

This started to happen a few weeks ago, sometimes it works, sometimes it does not. When I try to run pip install, it gives me this error: The command "pip install --user awscli" failed and exited with 1 during.`

I tried upgrading pip with pip install --upgrade pip but gives me the same. I also tried a “workaround” with pip install --trusted-host pypi.org --trusted-host files.pythonhosted.org --user awscli but nothing ensure me to work.

Before that error, there’s one message like this: No matching distribution found for awscli. I got in to debug mode and try to run the scripts manually, but it is the same, the last time I did it, I was running and running the same script, and suddenly, it works with no difference. Is there something we’re missing about new features in Travis?

Here’s my travis.yml

language: node_js

dist: trusty

node_js:
  - "8.5"

services:
  - docker

install:
  - npm i -g eslint@5.0.1
  - pip install --user awscli

before_script:
  - chmod +x ./scripts/lint-check.sh
  - chmod +x ./scripts/travis/*.sh
  - chmod +x ./scripts/coverage_report/*.sh
  - chmod +x ./services/core/scripts/*.sh
  - ./scripts/travis/aws-secrets-export.sh

script:
  - ./scripts/travis/docker-login.sh
  - ./scripts/travis/main.sh

after_success:
  - ./scripts/coverage_report/generate_coverage_reports.sh

1 Like

I have to work with trusty because, for some reason, my build does not work with xenial. Actually, in the past, we specified trusty because of this. I work with containers and in xenial, they dont work, they still waiting until 10m.

The linked post has a solution for Trusty as well.

Im so sorry, I’m not used to find this kind of solutions in this kind of communities, also I’m not a Native speaker, I can’t find the solution for trusty in Deprecation of non-SNI packages in python affecting `trusty`, could you please send me a link of the solution or how to find it?

There’s a link right there in the post: Deprecation of non-SNI compatible clients. · Issue #978 · pypa/pypi-support · GitHub

1 Like
Imprint