Our builds started failing with: bundler's executable "bundle" conflicts

Our Travis builds started hanging in the interactive prompt for a bundler conflict override the last couple of days.

gem update --system 
Updating rubygems-update
Successfully installed rubygems-update-3.1.1
Installing RubyGems 3.1.1
  Successfully built RubyGem
  Name: bundler
  Version: 2.1.0
  File: bundler-2.1.0.gem
bundler's executable "bundle" conflicts with /home/travis/.rvm/rubies/ruby-2.5.5/bin/bundle
Overwrite the executable? [yN]  

Example of build: https://travis-ci.com/ChangeX/changex-platform/jobs/268117079

We tried gem update --system --force or updating manually bundler before in the pre-install script but it didn’t fix it.

Our pre-install script is:

before_install:
  - "gem update --system"

Did something change recently?

4 Likes

I have encountered same problem let me know if you have a fix for this

It worked for me when I changed the before_install.
I removed gem update --system and added gem update bundler

1 Like

Removing gem update --system from before_install from .travis.yml file did work for me too.

Does it have something to do with the fact that Gem 3.1.0 started vendoring bundler?

Seemingly this vendored bundler is conflicting with rvm?

1 Like

Was able to circumvent the issue by specifying 3.0.3

gem update --system 3.0.3

Confirming that removing this gem update --system from our before_install, and specifying the version worked for us as well eventually.

Thank you everyone!

2 Likes

A fix was just pushed: https://github.com/rubygems/rubygems/pull/3040

1 Like
Imprint