Not able to push lfs files

Not able to push git-lfs files

trace:

Deploying application
632‘../dist/PSLab Setup 0.1.0.exe’ -> ‘./PSLab Setup 0.1.0.exe’
633‘../dist/win-unpacked/resources/app/node_modules/node-notifier/vendor/snoreToast/SnoreToast.exe’ -> ‘./SnoreToast.exe’
634‘../dist/win-unpacked/resources/app/node_modules/node-notifier/vendor/notifu/notifu64.exe’ -> ‘./notifu64.exe’
635‘../dist/win-unpacked/resources/app/node_modules/node-notifier/vendor/notifu/notifu.exe’ -> ‘./notifu.exe’
636‘../dist/win-unpacked/resources/elevate.exe’ -> ‘./elevate.exe’
637‘../dist/win-unpacked/PSLab.exe’ -> ‘./PSLab.exe’
638Switched to a new branch 'temporary'
639[temporary (root-commit) da7cb79] [Auto] Update Install Packages (2019-08-09.17:39:56)
640 7 files changed, 21 insertions(+)
641 create mode 100644 .gitattributes
642 create mode 100644 PSLab Setup 0.1.0.exe
643 create mode 100644 PSLab.exe
644 create mode 100755 SnoreToast.exe
645 create mode 100644 elevate.exe
646 create mode 100755 notifu.exe
647 create mode 100755 notifu64.exe
648Deleted branch install (was bc10d76).
649ERROR: Authentication error: Authentication required: You must have push access to verify locks
650error: failed to push some refs to 'https://adityastic:[OMIT]@github.com/adityastic/TestGEM'
651
652

script used:

#!/bin/sh

git config --global user.name "Aditya Gupta"
git config --global user.email "adityaofficialgupta@gmail.com"

git clone --quiet --branch=install https://adityastic:$GITHUB_API_KEY@github.com/adityastic/TestGEM install > /dev/null
cd install 

rm -rf *

find ../dist -type f \( -name '*.snap' -o -name '*.deb' -o -name "*.exe" \) -exec cp -v {} . \;

git checkout --orphan temporary
git add --all .
git commit -am "[Auto] Update Install Packages ($(date +%Y-%m-%d.%H:%M:%S))"
git branch -D install
git branch -m install

git push origin install --force --quiet > /dev/null

It use to work day before yesterday. public build can be at https://travis-ci.org/fossasia/pslab-desktop/builds/569133587?utm_source=github_status&utm_medium=notification

today I ran it with exe options and it does not seem to work with both the packages

If this worked with the same key and nothing changed in .travis.yml or the set of environment variables used by the build, maybe security settings for the repo and/or the branch you are pushing to changed, or the key was revoked. Since you are apparently able to log in to clone a private repository, the former is more likely.

Since this is a problem with Github rather than Travis, contact Github support if you require further assistance troubleshooting the permissions.

@native-api The build ran successfully before 2 days without any changes, like literally I just changed some files in the project and pushed. I tried setting up a completely new repository and same, I am able to push the repo but not able to push lfs objects. I’m sure it is not a github repository issue as I have tried running the same script on my machine, it works flawlessly. It use to work 2 days ago before the network issues with travis, If you wish to investigate setup a repo and try to push lfs objects to it over travis

Could you link to the problematic build?
(If it’s a private build, you can still link to it but only Travis support staff will be able to open the link.)

Imprint