Node.js build fails with no obvious error

#1

I have a build using Node.js on Windows and it errors out immediately after nvs use but there’s no obvious error.

5 Likes
Current known issues — Please read this before posting a new topic
Installing Node with nvm manually in Rust build
#2

@michaelmior I had the same exact issue. Same as you I had an secure environment variable defined in settings: https://travis-ci.org/hunterlester/safe_browser/jobs/458529411

Once I deleted the env var in my settings then the build went on as usual.
Of course I’m unable to deploy to Github but at least it’s documented now.
I’m able to set a non-secure env var though.

Hopefully Travis team is tracking these threads?

#3

Thanks @hunterlester! I didn’t think to check any connection with the environment variables. In my case, testing on Windows isn’t really critical so I just set allow_failures for now and I’m hoping I’ll see it go green in the future :slight_smile:

1 Like
#4

I am getting the same error:
https://travis-ci.org/JannisX11/blockbench/jobs/474419013
Is there any way I can fix it? I can’t get rid of the GH-Token variable because it is required to upload the builds to Github.

#5

We are all sharing the same pain :crazy_face:

1 Like
#6

Have you tried to place the variable before the command that requires it?
Because that did the trick for me :wink:

#7

@tibovanheule secure environment variables are set from the build settings on the UI.
Are you sure, you are using secure variables?

#8

Hey guys

I am experiencing the exact same issue and can confirm, removal of the secure environment variable from the settings fixes the build however as @JannisX11mentioned this prevents automatically uploading builds to Github.

Can anyone on the Windows team comment on timeframe for a fix for this as its a real blocker in my opinion.

2 Likes
#9

First thanks for starting Windows support on Travis!

I tried language: node_js but immediatelly running into an issue https://travis-ci.org/StefanScherer/travis-windows-test/builds/477693171 with nvs even before my first script command.

My .travis.yml looks like this

os: windows
language: node_js
services: docker

script:
  - docker version
  - docker images
  - npm install -g rebase-docker-image
  - rebase-docker-image -h
#10

Same problem :frowning: No fixes yet?

#11

If it helps, the error does not suggest issue with env variable, instead it looks like an odd version mismatch:

  • .travis.yml has node_js defined as 10.15.1
  • nvs ignores 10.15.1 and downloads 10.12.0 instead:
    Downloading bootstrap node from https://nodejs.org/dist/v10.12.0/node-v10.12.0-win-x64.7z
    
    Then silently fails.

I can confirm the error goes away if I remove secure environment variable as suggested in:

#12

This assessment is incorrect. nvs needs a known working Node.js installation to bootstrap, and it uses 10.12.0 at the moment. After that, it will install the desired version.

1 Like
#13

Just ran into the issue and it looks like there is no real solution. I can’t turn off secure variables though. Oh well :frowning:

#14

Also ran into the same issue with a secure env variable set