No output has been received in the last 10m0s while trying to restore cache

During cache restore:
https://travis-ci.org/tapika/test_travis_ci/jobs/587618706

I’m receiving timeout, while trying to restore cache:

adding C:/dev1/out to cache
creating directory C:/dev1/out
No output has been received in the last 10m0s, this potentially indicates a stalled build or something     
wrong with the build itself.
Check the details on how to adjust your build configuration on: 
https://docs.travis-ci.com/user/common-build-problems/#build-times-out-because-no-output-was-received
The build has been terminated

Cache size is indeed large, and it should be such, otherwise not possible to build whole environment.

Is there any way to fix this issue ?

I’m sorry, but besides reducing the cache size from 1.8 GB, there is not much we can suggest.

@BanzaiMan How did he even manage that in the first place? In my experience, throttled upload speed at a worker effectively limits cache size to something on the order of a gigabyte or so. (And it also ensures that you cannot upload what you cannot download afterwards.) Was this throttling lifted or something?

What I have briefly analyzed on my own pc - release builds of cling are approximately 2 Gb in size, debug however is much bigger - 13 Gb. In theory it’s possible to build each component individually and then somehow recombine all pieces of puzzle in final build. Final build in my case would be cling or libcling, and what I have checked with windirstat - biggest consumers in disk space are (for windows, linux has same problem, but haven’t analyzed it) cling.ilk - 1.1 Gb, libcling.ilk - 918 Mb. I could try to turn off incremental building - but that is already complex step (as need to analyze windows and linux situation separately) - but that would not help me much - lib folder (precompiled libraries with debug information) consumes 6.8 Gb, and reducing that one requires stripping off debug symbols.

Stripping off debug symbols means making release build, which I have already made.

Would it be possible to set some timeout for cache upload / download (in respect of total timeout of 50 min) ?

I’m not sure how you upload cache - is it in individual files, or everything compressed in .gz, but that one changes from build to build. (incremental build, retain previous build results)

Any solution for this one ?

Imprint