Nixpkgs no longer supports Nix 2.0.4

Builds configured using language: nix currently run into the following error:

Nix support for Travis CI is community maintained.
Please open any issues at and cc @domenkozar @garbas @matthewbauer @grahamc
$ nix-env --version
nix-env (Nix) 2.0.4
$ nix-instantiate --eval -E 'with import <nixpkgs> {}; lib.version or lib.nixpkgsVersion'
error: evaluation aborted with the following error message: '
This version of Nixpkgs requires Nix >= 2.2, please upgrade:
- If you are running NixOS, `nixos-rebuild' can be used to upgrade your system.
- Alternatively, with Nix > 2.0 `nix upgrade-nix' can be used to imperatively
  upgrade Nix. You may use `nix-env --version' to check which version you have.
- If you installed Nix using the install script (,
  it is safe to upgrade by running it again:
      curl | sh
For more information, please see the NixOS release notes at or locally at
If you need further help, see

This is even before any user build steps. I think the build environment needs a more recent Nix version to be compatible with the latest Nixpkgs.

cc @domenkozar @ garbas @matthewbauer @ grahamc (I am not allowed to cc all of the 4 suggested users because I am a new user.)