Cannot run Travis with Nix 2.2 or 2.3

The documentation for the nix: version specifier says:

Note: This option supports all Nix releases, starting with version 1.11.16.

But I attempted today to use Travis to test a Nix build with Nix 2.2 and it failed with the following error (also fails in the same way with Nix 2.3, 2.3.2, 2.3.3 and 2.3.4):

curl: (60) server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

Note that I confirmed it works fine with Nix 2.3.5 and 2.3.7.

cc @domenkozar @matthewbauer

Hi,

I’m facing the same error with various builds that use to fetch (git) stuff from several servers.

Just guessing (given the dates) if the problem is related with DST Root CA X3 Expiration (September 2021) - Let's Encrypt

I had the same problem in some own computers (xenial and focal) and had to perform an apt update & upgrade to get newer openssl & certificates-ca packages. After that, everything was back to work.

Maybe the travis environments don’t have those packages updated? I’ve tried here rerunning some jobs with xenial, bionic and focal and all them are failing with the same error.

Just a theory, but the date where errors began is a good coincidence.

Ciao :slight_smile:

3 Likes

I have the same issue here with my builds. It’s strange that 4 days passed and it’s still not fixed by Travis team.
UPD: Travis support provided following workaround for .travis.yml file until it’s fixed:

before_install:
  - sudo apt update && sudo apt install libgnutls-openssl27 libgnutls30
1 Like
Imprint