New member of org - invalid username or password after successful build - no changes

Hey Travis community!


  • I joined a small organization recently, which has enough credits. My association with the org appears in both Travis and Github.
  • I submitted and merged a PR on a documentation repo on Github. Minor change. Got approved and I merged it.
  • Travis triggered the build. The previous build was done by another member of the org, say “Adam”, a couple of months prior.
  • The travis.yaml file contains all the GIT_UID and GIT_TOKEN from the owner of the org, as it has for some time now.
  • The Build appeared to be successful but the changes never reflected on the html.
  • Upon close inspection, towards the end of the Build logs, it reads:
$ git push --force --quiet "https://${GIT_UID}:${GIT_TOKEN}" master:gh-pages
remote: Invalid username or password.
fatal: Authentication failed for ''

You can see the build HERE. In particular, the snippet shows up on lines 1270-1272.

  • “Adam” later merged a separete PR on Github. Got the same error as I did. The html files still has not updated from the previous 2 PRs.
  • The changes do appear in the github repo.

What I tried afterwards

I noticed that I get a message that reads:
“Select a Plan”, telling me that I could not trigger any build until I joined a plan. I am triggering a build on the organization repo, but I figure I would try. So I joined the Free Plan just in case. And with that I restarted the build of both mine and “Adam” build attempts. Got the same error as before.

Hope somebody with knowledge on this can help me out.

We figured out that the issue indeed was with the GIT_UID and GIT_TOKEN. They had worked fine for a long time but for whatever reason they were not working anymore. The owner of the org regenerated new ones and now the build is up and running.

Thanks for sharing.