Miniconda from Chocolatey has DLL fail for PyQt5

I’ve been testing this for at least a week now and have finally gotten to the point that I don’t think there is much more that I can do. This only seems to be a problem with Travis and only with Windows, but could be a problem specifically with Chocolatey or I’m just missing some small thing to get it to work.

I have stripped down my environment to the simplest form that I can think of so it:

  1. Installs miniconda
  2. Does “conda init” and resources .bash_profile.
  3. Creates a new environment with pyqt installed in a Python 3.7 environment.
  4. Try python -c "from PyQt5.QtWebEngineWidgets import QWebEngineView" and it fails with:
Traceback (most recent call last):

  File "<string>", line 1, in <module>

ImportError: DLL load failed: The specified module could not be found.

Here is the build: https://travis-ci.org/github/ssec/sift/builds/661182075

I have almost no experience tracking down DLL issues on Windows so any help would be very appreciated. Note that this works fine on a real Windows machine with Miniconda installed directly. I don’t have a Windows box with Chocolatey available to me right now.

Edit: Also note I’ve tried this with conda-forge packages which include PyQt 5.12 and I’ve tried installing PyQt from PyPI (via pip) in to an environment with just Python 3.7 and that has the same issue.

Use dumpbin, Dependencies or Process Monitor. The last one is the most (the only?) reliable way but is a bit complicated.

1 Like

Thanks for the information. I first tried dependencies but that list was long and hard to tell what was the problem. I then followed your example of using procmon from the other thread and loaded it in a local Windows VM. It looks like the main issue is PyQt trying to load DirectX since our tests are on a GUI application. Based on what I’ve found here DirectX isn’t currently supported, right?

Yes, multimedia functionality is currently not supported.
You may want to vote on this feature request:

Imprint