MacOS job stays queued forever and then errors with a null log

Here is a build where the Linux jobs completed in ~35 minutes or less…

https://travis-ci.org/bokov/nsqip_emr/builds/603574177

…but the Mac job ran for over 7 hours and then errored with a null log file:

https://travis-ci.org/bokov/nsqip_emr/jobs/603574182

I tried re-running, same result. How do I find additional information about what’s going on?

I realize the MacOS image is an old one, but I don’t believe that is the cause of this problem because here I have a job that runs just fine on the same image.

The only substantive difference I see from my working xcode8.3 job is that in this one I need to do brew install pandoc-crossref. Unfortunately, I have no idea how to diagnose the failure any further than that because, as you can see, there is nothing in the log.

Has anybody else encountered this problem?

Thanks.

This may have been because the previous job within the build attempted to invoke codecov on a project that is not currently set up to support codecov analysis.

But, if that’s the case, then that’s a Travis CI bug because the failed codecov doesn’t prevent the offending job from being marked successful, and it silently somehow messes up the MacOS job.

Imprint