I have an error everytime I run this .travis.yml

#1

Every time I add this file it says could not parse .travis.yml please help
this is the file

language: android
sudo: required
jdk: oraclejdk8

android:
  components:
    - tools
    - platform-tools
    - build-tools-28.0.0
    - android-28
    
 licenses:
    - 'android-sdk-license-.+'
    
    
before_install:
  - yes | sdkmanager "platforms;android-28"
  - chmod +x ./gradlew
  
script:
  - echo "Hello! This is Travis"
  - ./gradlew build
  
before_cache:
  - rm -f  $HOME/.gradle/caches/modules-2/modules-2.lock
  - rm -fr $HOME/.gradle/caches/*/plugin-resolution/

cache:
  directories:
    - $HOME/.gradle/caches/
    - $HOME/.gradle/wrapper/
    - $HOME/.android/build-cache
#2

Indentation on license: is wrong. You need one more space.

1 Like