Heroku Deployment that use maven is failling due to ReasonPhrase:HTTPS Required

problem can be seen at https://travis-ci.org/sevntu-checkstyle/methods-distance/builds/644597932#L1906

Could not transfer artifact com.puppycrawl.tools:checkstyle:pom:8.29 from/to 
central (http://repo.maven.apache.org/maven2): Failed to transfer file: 
http://repo.maven.apache.org/maven2/com/puppycrawl/tools/checkstyle/8.29/
checkstyle-8.29.pom. Return code is: 501 , ReasonPhrase:HTTPS Required. -> [Help 1]

same build logs but a bit above for deploy phase:

-----> Java app detected
-----> Installing JDK 1.8... done
-----> Installing Maven 3.1.1... done
-----> Executing Maven
       $ mvn -Pheroku clean dependency:list install

during build there is different maven:

mvn version

Apache Maven 3.6.2 (40f52333136460af0dc0d7232c0dc0bcf0d9e117; 2019-08-27T15:06:16Z)

Possbily maven update should help - https://stackoverflow.com/a/59764670/1015848

Do you know what is driving the use of http://repo.maven.apache.org? They have disabled the use of HTTP, so you’ll have to configure the use of HTTPS instead.

It might be as easy as removing the maven cache, or some extra configuration in your repo somewhere. It could be configured in our utilities, but I didn’t find it.

According to this SO post, the version we are using (3.6.2) meets the update “requirement”.

Version during deploy is 3.1.1, it is specially installed for some reason, see log chunk in topic description.
But during build is 3.6.2

That “reason” must be https://github.com/sevntu-checkstyle/methods-distance/blob/101e94a2bf423720b655399e7d23f3430482afde/system.properties

1 Like

Thanks a lot for help.
It is definitely a reason, fixed in scope of https://github.com/sevntu-checkstyle/methods-distance/issues/50

Imprint