Heroku Deployment Failure

My app deployment to Heroku stopped working one day ago, (January 14th). I received the error: “API request failed. Message: Invalid credentials provided.”

This app has been online for many months and I’ve never had issues with deployment before. I use GitHub for version control. Testing and deployment to Heroku are automatically performed by Travis CI when any updates are pushed to the Master branch.

Here’s a link to the latest broken build: https://travis-ci.org/drichards211/revuer/builds/637772527

221 The command “npm test” exited with 0.
222 store build cache
224
225 1.66s$ rvm $(travis_internal_ruby) --fuzzy do ruby -S gem install dpl
226 Successfully installed dpl-1.10.14
227 1 gem installed
228
229 Installing deploy dependencies
230 Successfully installed multipart-post-2.1.1
231 Successfully installed faraday-1.0.0
232 Successfully installed rendezvous-0.1.3
233 Successfully installed netrc-0.11.0
234 Successfully installed dpl-heroku-1.10.14
235 5 gems installed
236
237 API request failed.
238 Message: Invalid credentials provided.
239 Reference:
240 Preparing deploy
241
242 failed to deploy

Nothing has changed on my end. I’ve updated all Node dependencies as a broad-spectrum inoculant, but the problem appears after the tests successfully complete and deployment is attempted by Travis. There appears to be a credentials handshake issue between Travis CI and Heroku.

Is there any chance this is a bug with the latest build?: “[skip ci] command is respected under all circumstances”

Thanks for the report. We will take a look. I don’t think that change is related to this issue.

We took a look, but can’t quite reason about why it started failing for you. Could you try re-encrypting your API key and let us know how it works for you?

1 Like

Thank you for taking a look at this. I’ve updated my API Token with Heroku. I entered: “travis setup heroku --force” from the command line to encrypt and embed the new API key into .travis.yml

Pushed the changes to the master branch on GitHub and I’m still receiving the same error. The app won’t deploy. I’ve tried opening a ticket with Heroku, but they won’t accept tickets on free applications, even though I’m paying for enhanced Dyno access. :confused:

After 24 hours, I re-encrypted the Heroku API token, again, and updated the value with .travis.yml. This time it actually worked; a successful deployment. No other changes. Mystifying.

Imprint