Github Pages deploy failing on Trusty: dependency install error

github

#1

Failing under the csharp bot (trusty?)

Configuration:

language: csharp
addons:
  apt:
    sources:
    - deadsnakes
    - ubuntu-toolchain-r-test
    packages:
    - gcc-4.9
    - g++-4.9
    - cmake
script:
 - ./build.sh --target=LinuxDaily
deploy:
    edge:
        branch: v1.8.47
    provider: pages
    skip-cleanup: true
    github-token: $GITHUB_TOKEN
    on:
        branch: master
    local-dir: packaging/packages
repo: Librelancer/daily-builds

Relevant Log:

Installing deploy dependencies

ERROR: While executing gem … (OptionParser::InvalidOption)

invalid option: --no-ri

/home/travis/.rvm/rubies/ruby-2.4.1/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:54:in `require’: cannot load such file – octokit (LoadError)

from /home/travis/.rvm/rubies/ruby-2.4.1/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:54:in `require’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider.rb:85:in `requires’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider/pages.rb:26:in `<class:Pages>’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider/pages.rb:3:in `<class:Provider>’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider/pages.rb:2:in `<module:DPL>’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider/pages.rb:1:in `<top (required)>’

from /home/travis/.rvm/rubies/ruby-2.4.1/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:54:in `require’

from /home/travis/.rvm/rubies/ruby-2.4.1/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:54:in `require’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider.rb:59:in `const_get’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider.rb:59:in `block in new’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/cli.rb:41:in `fold’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/provider.rb:56:in `new’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/cli.rb:31:in `run’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/lib/dpl/cli.rb:7:in `run’

from /home/travis/.rvm/gems/ruby-2.4.1/gems/dpl-1.8.48.travis.241.1/bin/dpl:5:in `<top (required)>’

from /home/travis/.rvm/gems/ruby-2.4.1/bin/dpl:23:in `load’

from /home/travis/.rvm/gems/ruby-2.4.1/bin/dpl:23:in `<main>’

failed to deploy


#2

Why are you using an old version of dpl?


#3

--no-ri being an invalid option is a different issue.


#4

Can u help me fixed it