Gh-pages deployment failing

I’m deploying generated docs to gh-pages. It works on linux and mac, but it’s not working on windows. This is an example build log: https://travis-ci.com/nico-abram/rusty-boy-advance/jobs/212157348 . Regardless of this issue, I’m interested in if I can’t setup the gh-pages deployment to only actually deploy in one of the build matrix elements (Like, only linux 64bit). But anyways, I tried explicitly copying to C:/Users/travis/build/nico-abram/rusty-boy-advance/public but it still didn’t work. I’m currently trying to copy to public. (WIth the dot). This is what my yml looks like for the deployment configuration: https://github.com/nico-abram/rusty-boy-advance/blob/master/.travis.yml#L48-L55

Thanks!

You can use verbose: true in the deployment clause to get more info on what’s happening.

My initial guess is that the Windows image doesn’t have rsync, which is used by the deployment provider. (And therefore it doesn’t work on Windows as is.) You may try installing rsync yourself to confirm/refute this.

As for deployment in general: it is not a good idea to fire deployments from multiple jobs, unless each job works with disjoint parts, because they can occur simultaneously and interfere with each other. Consider using conditional deployment to restrict deployment to only one job, or using build stages to ensure that only one job is responsible for deployment.

1 Like

Thanks! I fixed it by manually exploding the build matrix and only setting the deployment on one element. But using conditional deployment seems way smoother so I’ll probably change it to that.

Again, thank you!

Imprint