Flask do_request_teardown issue

Hi,

I recently started to experience issue during tests of my flask application. I even tried to restart some old job to confirm that the issue is not caused by the PR that is being tested. The tox tests are working fine on my Fedora 34 machine, but failing on Travis - CI.

Here is the link for the job: Travis CI - Test and Deploy Your Code with Confidence

Hey @Zlopez,

I’m wondering If you dump the traceback on a SIGSEGV signal if you’d get the same or similar output? The other thing I noticed is you’re still using .org, I recommend migrating at this point to .com.

Thanks, do you mean to dump the traceback during SIGSEGV in tests or in travis build?

I will try to migrate to .com tomorrow and will see if this will help with the issue.

Most of the Pallets’ projects have been upgraded with breaking changes recently. I’d suggest you to pin Flask < 2 maybe to see if my guess is right — I think your local .tox/ folder has a pre-cached env that has old dep versions while in Travis some have been updated because they are not pinned in the requirements/contraints files.

Just compare the succeeding build Travis CI - Test and Deploy Your Code with Confidence and the failing one Travis CI - Test and Deploy Your Code with Confidence — these deps lists are pretty different.

I don’t think the dependencies are the issue here, I tried to recreate my local .tox folder and didn’t encountered this issue.

But I see that I don’t have flask in requirements.txt at all, I will try to add it. It’s probably installed as dependency for something else.

@webknjaz You were right, setting the Flask version in requirements.txt to < 2.0.0 did the trick. Thank you

Imprint