Different behaviour in debug mode

Hello,
since my build keep failing I tried to run it in debug mode.
If I run it using the travis_run_* commands, it fails also in debug mode with the same error. On the other hand, if I copy, paste and run all the commands one by one, everything goes well. Why?

The build fails when my program try to read a file which is in a volume mounted in a docker container, and it does not find it (while actually it is there, and I have no problems if I run the command manually).

This is the build: https://travis-ci.com/ldsec/medco-deployment/jobs/283826242/config

What commands are behaving differently?

I noticed that your configuration contains a lot of backslashes.

I don’t know what commands you are copying and pasting, but the docker-compose command in question in your build contain these backslashes, which may not be a part of your pasting.
https://travis-ci.com/ldsec/medco-deployment/jobs/283826242#L4823
In other words, you might be pasting

docker-compose -f docker-compose.tools.yml run medco-loader-srv0 v0 \ --ont_clinical /data/genomic/tcga_cbio/8_clinical_data.csv \ --sen /data/genomic/sensitive.txt \ --ont_genomic /data/genomic/tcga_cbio/8_mutation_data.csv \ --clinical /data/genomic/tcga_cbio/8_clinical_data.csv \ --genomic /data/genomic/tcga_cbio/8_mutation_data.csv \ --output /data/

but your docker-compose command is seeing the actual \.

I am not sure to understand what is the problem with backslashes, I use them all the time to split long bashes command in multiple lines. Why it does not work this way in Travis? Anyway, now that I removed them, everything works. Thanks!

Imprint