CI tests fail on latest Node with ENOENT for `./node_modules/fsevents/node_modules/<etc>`

$ nvm install node
$ node --version
v15.11.0
$ npm --version
7.6.0
$ nvm --version
0.37.2
$ npm ci 
npm ERR! code ENOENT
npm ERR! syscall chmod
npm ERR! path /home/travis/build/dhowe/ritajs/node_modules/fsevents/node_modules/detect-libc/bin/detect-libc.js
npm ERR! errno -2
npm ERR! enoent ENOENT: no such file or directory, chmod '/home/travis/build/dhowe/ritajs/node_modules/fsevents/node_modules/detect-libc/bin/detect-libc.js'
npm ERR! enoent This is related to npm not being able to find a file.

Link to the failing build:
Travis CI - Test and Deploy Your Code with Confidence

Note that the build works locally with the same versions/commands locally

Since it’s in node_modules, cleaning the cache will likely help.

If not, that’s most likely a problem with some of the 3rd-party packages.

You are not actually cleaning the cache.

language: node_js jobs have a default implicit cache clause (for node_modules or .npm depending on your repo’s contents).

To clean it, go to More options -> Caches on a build page.

To disable or otherwise control it, see Building a JavaScript and Node.js project - Travis CI

Imprint