Cannot sign in in Travis with github - SyntaxError: JSON.parse

Hi,
I noticed yesterday that I cannot log in any more to Travis CI. When I click on the “sign in with github” button I receive this error:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

I cleaned the cache and removed all storages (cookies, local storage, session storage, index db) for both github.com and travis-ci.org but it did not solve the issue.

1 Like

Please, can someone provide some hints about this? I am still not able to login.
Is there a better place for getting help for this kind of issues?

I have the same issue. Registration and the initial login one week ago still worked but not I have that problem. I can’t even log into travis-ci.community, I get

Authorization timed out, or you have switched browsers. Please try again.

I did not use Travis in any other browser between my initial signup and this error.

However, as I’m writing now here, I’ve switched browser to Opera (from Firefox) and it works there. I’ve not updated my browser or its addons inbetween the first signup and the erroneous login.

Did you do the same for travis-ci.com?

Using a private browser window (if your browser supports such) is also useful to check if some cookies are an issue.

I solved the problem for me. The problem is containers and especially websites configured to automatically opening inside a container.

So, here I’m trying to log into Travis without any container but the login tries to query github and github is automatically opened in a new “Personal” container. The fix would be to configure github to not open automatically in any container or to simply log into Travis in the same container as you are logged in to Github.

1 Like
Imprint