Cannot apt-get install clang-5.0

#1

This only stopped working recently. I cannot install clang-5.0 from llvm-toolchain-trusty-5.0. The error I get is:

The following packages have unmet dependencies:
 clang-5.0 : Depends: libjsoncpp0 (>= 0.6.0~rc2) but it is not installable
E: Unable to correct problems, you have held broken packages.

The full command and error can be found here: https://travis-ci.org/ericniebler/range-v3/jobs/526944526

Did something change recently? Any workarounds?

Thanks,
Eric

#2

Related: https://askubuntu.com/questions/223237/unable-to-correct-problems-you-have-held-broken-packages, https://askubuntu.com/questions/441537/apt-returns-e-unmet-dependencies-when-i-try-to-install-a-package-how-can-i-d

#3

The default build environment has been updated from Trusty to Xenial.

To keep using Trusty you can set: dist: trusty
Or use Xenial and remove the llvm-toolchain-trusty-5.0 etc. since clang-5.0 (and 4.0 and 6.0) are available in the default Apt packages. clang-5.0 @ packages.ubuntu.com.

Note that Trusty is EOL.

1 Like