Build fail with gulp 134


#1

Since about a month, all my builds fail with:

gulp[4953]: ../src/node_contextify.cc:628:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x8daaa0 node::Abort() [gulp]
 2: 0x8dab75  [gulp]
 3: 0x90e2f7 node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp]
 4: 0xb5e71b  [gulp]
 5: 0xb606b2 v8::internal::Builtin_HandleApiCall(int, v8::internal::Object**, v8::internal::Isolate*) [gulp]
 6: 0xf8f4e35be1d 
/home/travis/.travis/job_stages: line 104:  4953 Aborted                 (core dumped) gulp
The command "gulp" exited with 134.

(complete log)

Do you have an idea how I can fix that?


#2

First, try deleting the cache.


#3

Do you mean deleting Travis’ node_modules cache?
I commented out travis.yml like this:

# cache:
#   directories:
#     - node_modules

but the same error is returned: build log


#4

Looks like a problem with the Node engine.

Quick googling reveals https://github.com/nodejs/node/issues/20325 .


#5

Thank you, indeed the npm i natives “solution” did the trick, but I don’t understand why and if it’s a good thing to use it. Anyway, we could say it’s a solved topic, thanks!