Bug nod_js 16 on Windows

This Config works fine on linux and osx. It breaks only on windows and only on version 16:

  "os": [
    "linux",
    "osx",
    "windows"
  ],
  "language": "node_js",
  "node_js": [
    "16"
  ],

It seems that something wrong with the VM:

on linux:

120> iobroker.growatt@1.1.1 test:unit
121> node_modules/.bin/mocha test/unitAdapter --exit
122
123
124
125 Unit tests
126Unit tests for adapter startup are deprecated!
127If you do not define your own tests, you can remove the "test:unit" script
128from package.json and from your Travis/Github Actions workflow.
129 ✓ DEPRECATED!
130
131
132 1 passing (7ms)
133
134The command "npm run test:unit" exited with 0.
1350.01s$ export DEBUG=testing:*
136The command "export DEBUG=testing:*" exited with 0.
13743.42s$ npm run test:integration
138
139> iobroker.growatt@1.1.1 test:integration
140> node_modules/.bin/mocha test/integrationAdapter --exit
141
142 testing:integration:ControllerSetup Creating ControllerSetup... +0ms

on windows:

80> iobroker.growatt@1.1.1 test:unit
81> node_modules/.bin/mocha test/unitAdapter --exit
82
83The command "npm run test:unit" exited with 1.
840.03s$ export DEBUG=testing:*
85The command "export DEBUG=testing:*" exited with 0.
860.74s$ npm run test:integration
87'node_modules' is not recognized as an internal or external command,
88operable program or batch file.
89
90> iobroker.growatt@1.1.1 test:integration
91> node_modules/.bin/mocha test/integrationAdapter --exit
92
93The command "npm run test:integration" exited with 1.
940.77s$ npm run test:package
95'node_modules' is not recognized as an internal or external command,
96operable program or batch file.
97
98> iobroker.growatt@1.1.1 test:package
99> node_modules/.bin/mocha test/packageFiles --exit
100
101The command "npm run test:package" exited with 1.
1020.77s$ npm run test:unit
103'node_modules' is not recognized as an internal or external command,
104operable program or batch file.
105
106> iobroker.growatt@1.1.1 test:unit
107> node_modules/.bin/mocha test/unitAdapter --exit
108
109The command "npm run test:unit" exited with 1.
1100.03s$ export DEBUG=testing:*
111The command "export DEBUG=testing:*" exited with 0.
1120.79s$ npm run test:integration
113'node_modules' is not recognized as an internal or external command,
114operable program or batch file.
115
116> iobroker.growatt@1.1.1 test:integration
117> node_modules/.bin/mocha test/integrationAdapter --exit
118
119

Why is ‘node_modules’ not recognized only by windows?

https://travis-ci.com/github/PLCHome/ioBroker.growatt/builds
#50 and #37-#45

Try converting the path separators from / to \\ in the exec parameter.

Imprint