Broken builds on PHP 7.4

I am getting this error when running tests on PHP 7.4.
(see https://travis-ci.com/github/miceno/providence/pull_requests)

PHP Fatal error: Uncaught DatabaseException: Lock wait timeout exceeded; try restarting transaction in /home/travis/build/miceno/providence/app/lib/Db/mysqli.php:316

They don’t show up on PHP 7.3 nor PHP 7.2.

It looks like it is back to normal, no problem as of now.

Back again broken! :frowning:

It is making all my builds errored :frowning:

Is there anybody also experiencing the same issue with 7.4 testing?

Have you tried what the error message by mysql suggests (try restarting the transaction)?

Thank you for your answer!

No, I didn’t. But I tried to rise the lock timeout to 300 seconds and the problem persisted :frowning:

The point is that the same code runs without any problem on 7.3 and 7.2.

My intuition is that there is something to fine tune on the 7.4 images, so I would like to know if there is somebody else with this issue, and then try to escalate it.

Regards.

I’ve never run over such an issue. Checked: The Mysql Server is the same (compared with the 7.3 build-> 5.7.29-0ubuntu0.18.04.1) maybe diffing the PHP mysqli configuration between 7.3 and 7.4?

My suggestion with restarting the transaction was not that resourceful as I’ve now seen it is within a migration script. If for some reason the query is different though, it might be worth to log it in full.

Have you tried running it on a different system than Travis with that Mysql and PHP version?

It really seems like a application-specific issue to me. The best way to move forward is to run debug builds to understand it.

I’ve enabled the feature for your repo, so that you can get started.

Thank you!

I will give it a try and come back here with the results.

Imprint