Windows build - long path for files

travis-build

#1

Hello Travis Dev and other people that will read this post,

Congratulations for the Windows support !! :fireworks:

Even if it is in Early access stage, I would like to give you some feedback about a problem that I have encountered on Windows build.
For some context, I’ve tried to set up on the c++ windows environnement on Travis for the company I’m working for, and I have encountered a problem during the checkout of the repository in the windows build.

It seems that the environment can’t checkout files with a long path/filename with can occurs on some repositories. This is a recurring problem on git with windows, we already have faced it on our local machine, and we had to run the command git config --system core.longpaths true to fix the problem.

But on Travis, the repository is checked out early, so I don’t know how I can run the command git config --system core.longpaths true before the windows build start checking out our repository, or if you have to integrate this command line from your side of Travis.

I hope that I’ve been clear about the problem I’m facing.
Thanks again for your amazing work.

Thanks in advance for your time,
Xavier Jouvenot


#2

Thanks for pointing this out.

According to https://ourcodeworld.com/articles/read/109/how-to-solve-filename-too-long-error-in-git-powershell-and-github-application-for-windows, the limit is 260 characters for git compiled with the older API. Seems that there is no downside to setting this config option to true, so we should do that universally.